[css-scroll-snap] Renaming scroll-snap-area to scroll-snap-margin

On the snapping container, we have scroll-snap-padding, because it
acts like padding.  On children, the property currently known as
scroll-snap-area acts like margins, but we named it "area" because it
originally also controlled which box of the element was being snapped

Since we simplified it to always snap to the border box, the property
has been simplified to just 1-4 <length>s, and is thus identical to
the 'margin' property.  It would probably make sense to switch the
name to match, and call it 'scroll-snap-margin' instead.


~TJ and fantasai

Received on Friday, 15 January 2016 20:24:24 UTC