Re: [css-flexbox] Renaming flex-basis:auto for less confusion

On 7/1/14 9:01 AM, "Tab Atkins Jr." <> wrote:

>At the last f2f, we discussed the fact our current usage of "auto" in
>'flex-basis' is sub-optimal.  For one, it means that it's impossible
>to explicitly ask for "auto" sizing behavior from 'flex-basis': you
>have to set "flex-basis:auto" to make it draw from 'width', then set
>"width:auto" to transmit the auto-sizing behavior to it.  For two, as
>illustrated in the previous sentence, "auto" in 'flex-basis's computed
>value means something *completely different* to "auto" in its used
>value, which is confusing and weird.

Argh! This aspect never bothered me personally. My own confusion was more
with the actual shorthands, such as 'flex:none' having a 'flex-basis' of
'auto', where having both 'none' and 'auto' in the same context was weird.

>We suggest ''main-size'' for the new keyword. dbaron pointed out that
>the term "main" doesn't actually show up in the author-facing API, but
>it does show up *everywhere* in the spec itself, so hopefully this
>will be adequate.  We can bikeshed this name further if necessary.

I'd suggest 'auto-size' if the keyword must be different. 'main-size' seem
right but sound a bit like an end result as opposed to what it draws from.
Or perhaps 'flex-size'.

Received on Wednesday, 2 July 2014 10:05:53 UTC