W3C home > Mailing lists > Public > www-style@w3.org > May 2012

Re: [css-variables] CSS Variables are a NEW kind of variable

From: John Daggett <jdaggett@mozilla.com>
Date: Wed, 30 May 2012 20:44:06 -0700 (PDT)
To: Sylvain Galineau <sylvaing@microsoft.com>
Cc: Divya Manian <manian@adobe.com>, Fran├žois REMY <fremycompany_pub@yahoo.fr>, www-style@w3.org
Message-ID: <566829631.23387500.1338435846435.JavaMail.root@mozilla.com>
Sylvain Galineau wrote:

> Not to prove that everyone's preference is someone else's ugly but I
> can't stand the x-convention. If we're going to have a prefix why
> not make it something readable. For instance:
>         :root { define-link-color: blue }
>         a { color: $link-color }
> ...is imo a reasonable balance: terse at the point of use and very
> explicit at the point of declaration since there should be many of
> the former for each of the latter.

This seems like a reasonable compromise.  Maybe shorten the 'define'

  :root { def-link-color: blue }
  a { color: $link-color; }

I'm not a huge fan of the prefix-foo syntax either but I think it's
better than mucking with the core syntax simply to jam in the parsing
of $foo for variable definitions. On the use side, having to wrap
prefix() around everything hurts the readability, especially in


John Daggett
Received on Thursday, 31 May 2012 03:44:36 UTC

This archive was generated by hypermail 2.4.0 : Friday, 25 March 2022 10:08:17 UTC