W3C home > Mailing lists > Public > www-style@w3.org > May 2012

RE: [css3-flexbox] alignment names (RE: Bikeshed ALL the things)

From: Alex Mogilevsky <alexmog@microsoft.com>
Date: Wed, 30 May 2012 18:36:22 +0000
To: Fran├žois REMY <fremycompany_pub@yahoo.fr>
CC: CSS 3 W3C Group <www-style@w3.org>
Message-ID: <2C86A15F63CD734EB1D846A0BA4E0FC823C9B2C5@CH1PRD0310MB381.namprd03.prod.outlook.com>
> From: Fran├žois REMY [mailto:fremycompany_pub@yahoo.fr]
> Sent: Wednesday, May 30, 2012 9:23 AM
> To: Alex Mogilevsky
> Cc: CSS 3 W3C Group
> Subject: Re: [css3-flexbox] alignment names (RE: Bikeshed ALL the things)
> Are you asking for something like
>     {
>         justify-self: justify;
>     }
> ?
> The "space-around" choice may seem strange to you, but it's at least
> consistent with the first choice that was voted: you can't decently use a
> part of a property name as its value to mean something different that it
> uses to mean in the property name.
> This is not to say I like the whole "justify" thing, but at some point the
> WG need to make a decision, isn't it?

This is a problem with naming a property with what is already a value for another property -- "text-align:justify" is there forever, it is well understood what it does and "flex-pack:justify" was doing exactly same until it was renamed last week.

Not sure how we have arrived to 'justify-***' as property name, as far as I can see it is not quite working out yet.
Received on Wednesday, 30 May 2012 18:39:13 UTC

This archive was generated by hypermail 2.4.0 : Friday, 25 March 2022 10:08:17 UTC