That would be my vote as well... flexbox-flex would go away if we adopt flex units (which I think we should strongly consider doing).
dave
On May 25, 2010, at 8:01 PM, Alex Mogilevsky wrote:
> My vote currently is for
>
> display:flexbox
> display:inline-flexbox
> flexbox-align
> flexbox-direction
> flexbox-flex
> etc.
>
> yes, ‘flexbox-flex’ looks odd but the whole naming system is very clear.
>
> I also prefer ‘orientation’ to ‘orient’.
>
> From: www-style-request@w3.org [mailto:www-style-request@w3.org] On Behalf Of Ojan Vafai
> Sent: Tuesday, May 25, 2010 3:58 PM
> To: David Hyatt
> Cc: Tab Atkins Jr.; www-style list
> Subject: Re: Flexbox Draft, with pictures!
>
> On Tue, May 25, 2010 at 3:46 PM, David Hyatt <hyatt@apple.com> wrote:
> (1) I don't think "flex" by itself is a good term for display-inside. I also agree that "box" is arguably too generic. You might consider just combining the words flex and box together.
>
> display: flex-box
> display: inline-flex-box
>
> The same would apply to other properties, e.g., flexbox-begin not flex-begin.
>
> The original version of Tab's spec used "flexbox". What's you're issue with just "flex"? flexbox seems redundant to me.