Re: CSS3 Paged Media Draft

On Wed, 29 Sep 1999, Sjoerd Visscher wrote:

> One thing:
> 
> I think it's a bit confusing that 'content()' flattens out the text. I think
> you'll get the "hey, why is all my markup gone??". Call it 'text()'. And
> keep 'content()' to represent the exact content of the element (it should
> then be disallowed in set-string). This way (the annoying) :before and
> :after are not needed anymore.

Not true, since you can style :before and :after, but cannot style
different parts of the 'content' property. For example:

   c:before { border: solid blue; padding: 1em; display: block; ... }

I agree, though, that content() could be renamed so that it is clear
that it flattens the tree. I am less sure that having a function which
returns a copy of the children would be a good idea, though. How would
you cope with things like this:

   <x>
     <span id="one"> ids </span>
     <script type="text/plain">
        Something which manipulates the DOM
     </script>
   </x>

...with this style?

   x { content: content() content(); }

The only way around that I can see would be to say content() can only
be used in the 'content' property of that element, and then only once.
And we would not be able to have target-content().

But now we've exactly duplicated the functionality of :before and
:after, so what is the point?

-- 
Ian Hickson
: Is your JavaScript ready for Nav5 and IE5?
: Get the latest JavaScript client sniffer at 
: http://developer.netscape.com/docs/examples/javascript/browser_type.html

Received on Wednesday, 29 September 1999 18:40:05 UTC