W3C home > Mailing lists > Public > www-jigsaw@w3.org > January to February 2001

RE: More on PUT corruption

From: Bob Schader <bobs@product-des.com>
Date: Tue, 27 Feb 2001 11:06:21 -0500 (EST)
To: "Jigsaw List" <www-jigsaw@w3.org>
Message-ID: <HFEMINDGIADFIPHHOLOGAEPCCBAA.bobs@product-des.com>
I will see if I can set up a test doing that. Maybe I will
try both jigsaw and Apache (with mod-dav for PUT support).
I wonder if this might be due to having a bad memory chip
or something which is corrupting the file in memory.

Bob Schader
CAD Systems Admin
Product Design Intl., Inc.
4880 36th St. SE, Suite 100
Grand Rapids, MI 49512
(616) 667-2600 x104

-----Original Message-----
From: Michael Zick [mailto:mszick@altavista.net]
Sent: Tuesday, February 27, 2001 9:19 AM
To: Bob Schader
Cc: Jigsaw List
Subject: Re: More on PUT corruption

A suggestion...
Have you tried doing a "PUT" to "localhost:xxx" ?  That is, the data
being transferred would never leave the physical bounds of the machine,
but should use the same JDK/TCP/IP/OS paths of an external connection.
Of course, you would have to have a local HTTP server running – so you
might have to proc up the Jigsaw server on each of the two machines
during the testing so that your could "PUT" to yourself.


>>>>>>>>>>>>>>>>>> Original Message <<<<<<<<<<<<<<<<<<

On 2/27/01, 06:44:57, Bob Schader <rschader@product-des.com> wrote
regarding More on PUT corruption:

> Found out today that the problem I am having seems to
> be because of something on my home system. I did not
> have the problem at all at work, everything worked as
> it was supposed to.

> So, then I found that my JDK at home was an older 1.3
> Release candidate, so I un-installed it and installed
> the same JDK as on my work computer, which is 1.3.0_01.

> So now the only difference I can tell between the 2
> systems is that one is Windows 2000 (the one that works),
> and the other one is WinNT 4.0 SP 6. I have found I even
> get the corruption using Winie's JWPut command line
> interface to upload a file now.

> I have also noticed that I also have some graphics refresh
> errors on my swing components, especially the menu bar,
> even with the new JDK installed.

> I see to actually be getting more errors using jwput
> than my own program, even after upgrading the JDK and
> rebooting. Funny, the connection at work is a full
> 100Mb, you'd think the faster transfer might be more
> prone to such errors! Yet the slower, 128Kb connection
> is the one giving me problems!

> Since this only appears to happen to me when trying
> to use the w3c client lib, is there some way I can tell
> it to do more error checking or something? Until this is
> resolved, I huess it's back to using native libcurls
> to do my uploads, as it hasn't failed yet.

> Bob Schader
Received on Tuesday, 27 February 2001 11:32:27 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 22:41:29 UTC