W3C home > Mailing lists > Public > www-jigsaw@w3.org > January to February 2000

RE: Jigsaw SSL to be continued

From: Mikael Petterson (BCS) <Mikael.Petterson@edt.ericsson.se>
Date: Wed, 9 Feb 2000 11:15:40 +0100
Message-ID: <33C9100DDE98D211A16D0008C7A4E3FE05FC7BDA@esealnt103>
To: "'Yves Lafon'" <ylafon@w3.org>, "'Benoit.Mahe@sophia.inria.fr'" <Benoit.Mahe@sophia.inria.fr>, "Arne Riiber(ETO)" <Arne.Riiber@eto.ericsson.se>
Cc: "'www-jigsaw@w3.org'" <www-jigsaw@w3.org>

I have now changed to jdk1.2.1_04 (Production version).
I resinstall the whole server+IAIK package.
I start server and get the server working and I place servlets that have no properties. They work fine.

Then I take the servlet that I will use ans that has one property. I go into the admin tool and try to edit one parameter.I do commit and save for that server. I get the same error message as below. Has anyone used parameter settings in Jigsaw 2.0.1? I have not found anything in your mailing lists!

Also we have been in contact with IAIK. They had a version of Jigsaw 2.0.4 (source patches) on their site. Mr Peter Lipp said he got the version from Jigsaw team. See the mail we sent to Lipp:

Dear  masters of JigsawSSL!

This is a request for help to get JigsawSSL-2.0.4 up and running.

We have a project working with mobile electronic commerce, we develop
using IAIK crypto library.
We liked JigsawSSL-2.0.1 since its Java, easy to download, install and

Since we could not figure how to set up servlet.properties in 2.0.1, we
have tried the update for Jigsaw-2.0.4.
Unfortunately, after some hours of effort, we still could not get
JigsawSSL-2.0.4 up and running.
We have compiled the source tree from updated-src-ssl.tar.gz into

When starting 2.0.4, we do not get any 'class not found exceptions', and
the server says 'serving at https://cyan276.era-a.ericsson.se:4434', but
we do not get the 'creating new default SSLContext...' message, the
Swing classes are not loaded, and we are never asked for keystore

Have tried JDK/1.1 and JDK/1.2, checked the CLASSPATH etc., even changed
our jigsaw-ssl.zip to the old version from 2.0.1, without success.
It looks like some files in the jigsaw-ssl.zip from the 2.0.1
(org.w3c.tools.*) are not in the source tree file updated-src-ssl.tar.gz

Do you have any hints to help us get it up and running?
It would be very convinient for us to get working versions of the
.jar/.zip files as an attachment, or a pointer to where we can pick them

Thanks for your cooperation,



We are in a lot of trouble now!

Please give us some help!


-----Original Message-----
From: Yves Lafon [mailto:ylafon@w3.org]
Sent: Tuesday, February 08, 2000 11:14 AM
To: Pettersson Mikael AV/G(TO/EDT/I/V)
Cc: Benoit.Mahe@sophia.inria.fr; edtmlpn@edt.ericsson.se
Subject: Re: Jigsaw SSL to be continued

On Tue, 8 Feb 2000, Pettersson Mikael AV/G(TO/EDT/I/V) wrote:

> "Pettersson Mikael AV/G(TO/EDT/I/V)" wrote:
> >
> > SignatureProxy=/home/edtmlpn/testinst/mjalda/cfg/sample/SignatureProxy.cfg
> >
> > I edit and then when I do commit I get the following in the window where
> > I started the Jigadmin:
> >
> > Warning:
> >     Name: slist
> >     Class: XmList
> >     Invalid item(s) to delete.
> >
> > Warning:
> >     Name: slist
> >     Class: XmList
> >     Invalid item(s) to delete.

Looks like a jdk bug. Xm is motif toolkit.

> > I close the Jigadmin and then I try to start it with the following
> > error:

Are you using jigadmin or jigadm? (the nice version or the old one? :) ).

> > # HotSpot Virtual Machine Error, Unexpected Signal 11
> > #
> > # Error happened during: scavenge
> > #
> > # Error ID: 4F533F534F4C415249530E4350500BC2 01

Hum. Hotspot on solaris is beta and is quite buggy, they released an
update for win* but not for solaris yet... The best pick is jdk1.2.1_04

      /\          - Yves Lafon - World Wide Web Consortium - 
  /\ /  \        Architecture Domain - Jigsaw Activity Leader
 /  \    \/\    
/    \   /  \   http://www.w3.org/People/Lafon - ylafon@w3.org    
Received on Wednesday, 9 February 2000 05:16:02 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 22:41:28 UTC