W3C home > Mailing lists > Public > www-jigsaw@w3.org > May to June 1996


From: Doug Marker <dmarker@zeta.org.au>
Date: Thu, 27 Jun 1996 07:49:47 +1100
Message-Id: <31D1A26B.7067@zeta.org.au>
To: www-jigsaw@w3.org

I think I have some sort of execution problem. When everything seems set 
up correctly, calling the CGI program results in the mouse pointer 
indicating busy - the staus line 'waiting for reply' but nothing 

If I execute the command in stand alone mode it works (a simple echoing 
of a message wrapped in HTML),

However, you were right about the command being defined as a file when 
it sent the source back. one of the many resource definitions I tried 
was to define the command as a file to see what would happen, then I 
forgot that this is what I had done - all the other definitions for 
resources in cgi-bin were correctly  defined as forms.CgiResource and 
these are when it hangs (both command scripts and *.exe) 

I may have to dive into the Java source & set some message checkpoints  
Again - thanks for your great pro-active support on this fascinating 

Cheers - Doug Marker
Anselm Baird-Smith wrote:

> This is really funny, at step 8 you could try exiting the server
> (/Admin/Exit), then restarting it, and check that your CgiResource has
> been saved properly, by looking at /Admin/Editor/cgi-bin/mycgitst. This
> should indicate that the class of this resource is
> w3c.jigsaw.forms.CgiResource (from what you tells, it looks that
> this is not the case).
> Normally your script should be accessible as
> http://yourhost/cgi-bin/mycgitst
> Also, (I can't remember now), but be sure to leave an empty new line
> right after the first command line (eg be sure to hit return after
> entering the full path of the script and before clicking the Ok
> button). This shouldn't impact anything, but Jigsaw is still in alpha
> stage ;-)
>  > My good judgement tells me I am doing the right thing - but perhaps missing a step somewhere.
>  > I have tried shutting down the server (a few times) tried new browsers - but no results
> The fact that Jigsaw is returning the text of your script seems to
> indicate that your resource is a FileResource rather then a
> CgiResource...
>  > Any advice will be most welcome but please make it step-by-step & so simple that a sales rep could
>  > understand it (a tough (perhaps impossible) request :-)
> Yep, it 's my hope that with an Applet based interface and more
> documentation, configuring Jigsaw is going to be so easy that even my
> father will be able to do it (this one is a really tough request ;-)
> Let me know how it goes...this should enable us to at least add a FAQ
> entry.
> Anselm.
Received on Wednesday, 26 June 1996 18:08:02 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 22:41:20 UTC