W3C home > Mailing lists > Public > www-jigsaw@w3.org > May to June 1996


From: Doug Marker <dmarker@zeta.org.au>
Date: Wed, 26 Jun 1996 19:48:00 +1100
Message-Id: <31D0F940.6039@zeta.org.au>
To: www-jigsaw@w3.org
Sadly I am missing something here. Having spent a couple of days trying everything and reading 
everyone's words carefully on the matter I still cannot even get a simple test.cmd (an OS/2 REXX 
script from my prior server) to execcute - the only thing I ever get is the source to the test.cmd 
sent to me.

I also tried my executable (a C pgm) abtcgil.exe but cannot get it to do anything.

What I am tripping up on is trying to realte this to my experience with my previous servers.

In them I could say that if http://www.myhost/cgi-bin/test.cmd?Fred=FREDDATA&Bill=BILLDATA
was received, that 'cgi-bin' could be mapped to 'y:\cgipgms\cgi-bin\'

Despite reading all the docs and tutorials etc: I have no idea how to get test.cmd to execute. I 
cannot figure out what will happen to the HTML it generates even when it does work. 

The steps I am going thru are :-

1) I add a directory called cgi-bin (i.e. x:\Jigsaw\Jigsaw\WWW\cgi-bin
2) I put 2 files in that directory a)=test.cmd (an os/2 script (rexx)) and b)=abtcgil.exe (a C pgm 
compiled for OS/2)
3) I run http://www.myhost/Admin, select the editor to edit myhost/Admin/Editor/cgi-bin
4) (I have not added cgi-bin as a DirectoryResource as I could see nothing saying I should ?)
5) I then select AddingResources from the form presented in 3
6) I add resource 'mycgitst' with class w3c.jigsaw.forms.CgiResource
7) I go back by clicking ExistingResources and there is my new resource 'mycgitst', I click it
8) I enter into the command: text box x:\Jigsaw\Jigsaw\WWW\cgi-bin\test.cmd and leave 
generates-form: true - then click ok
9) I then try to access http://myhost/mycgitst - http://myhost/cgi-bin/mycgitst - 
http://myhost/cgi-bin/test.cmd etc: etc: etc: etc: (even tried adding cgi-bin as a 

My good judgement tells me I am doing the right thing - but perhaps missing a step somewhere.
I have tried shutting down the server (a few times) tried new browsers - but no results

Any advice will be most welcome but please make it step-by-step & so simple that a sales rep could 
understand it (a tough (perhaps impossible) request :-)

cheers -  Doug Marker
Received on Wednesday, 26 June 1996 06:07:03 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 22:41:20 UTC