XHTML

I do not particularly like the style of checked="checked" for input
types. It seems a little bit of overkill to have the repetition of
'checked' in the HTML source.

Surely a better approach would be to define a binary ENTITY type:

<!ENTITY % Boolean "(yes|no)" "no">

and then use that for checked and other things

<!ATTLIST input
  checked %Boolean; #IMPLIED
  disabled %Boolean; #IMPLIED
  readonly %Boolean; #IMPLIED
>

The boolean type could then be used in other boolean-style places, such
as multiple/disabled/selected

Does this not make far more sense than having a per-element specific
value?

Alex.

Received on Tuesday, 3 August 1999 08:16:25 UTC