W3C home > Mailing lists > Public > www-dom@w3.org > October to December 2013

[Bug 23698] New: Rename ParentNode to ContainerNode or some other unambiguous name

From: <bugzilla@jessica.w3.org>
Date: Fri, 01 Nov 2013 08:59:25 +0000
To: www-dom@w3.org
Message-ID: <bug-23698-4009@http.www.w3.org/Bugs/Public/>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=23698

            Bug ID: 23698
           Summary: Rename ParentNode to ContainerNode or some other
                    unambiguous name
           Product: WebAppsWG
           Version: unspecified
          Hardware: PC
                OS: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: DOM
          Assignee: annevk@annevk.nl
          Reporter: rniwa@webkit.org
        QA Contact: public-webapps-bugzilla@w3.org
                CC: mike@w3.org, www-dom@w3.org

The name ParentNode is exceedingly confusing because we already have
parentNode() on Node.  Talking about the parentNode() of ParentNode, for
example, will be very confusing.

In WebKit/Blink, we use call it ContainerNode since it's a node that could
contain other nodes.

I'm open to other names but please disambiguate from other DOM class and method
names.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Received on Friday, 1 November 2013 08:59:26 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 20 October 2015 10:46:21 UTC