W3C home > Mailing lists > Public > www-archive@w3.org > May 2005

trouble building pymedia from CVS; latest setup.py not checked in?

From: Dan Connolly <connolly@w3.org>
Date: Mon, 30 May 2005 16:28:23 -0500
To: dborisov@indashpc.org
Cc: www-archive@w3.org
Message-Id: <1117488503.19175.45.camel@localhost>

Hi... sorry to mail you directly;
I created an account and tried to post a reply in
this thread
  http://indashpc.org/vbullettin/viewtopic.php?t=84
but I'm losing for some reason.


I've got some video files that I'm trying to make sense of.

I started playing with pymedia, but I don't think I've got
it built right.

Browsing CVS, I see lots of:

"11 days  jbors  Restructuring of muxer"
-- http://cvs.sourceforge.net/viewcvs.py/pymedia/pymedia/audio/

but setup.py is much older. Perhaps you have a setup.py that
you haven't checked in?



Background...

I got a new camera (some details in
http://dm93.org/z2001/FilmKiller ). It takes video
clips in some .ASF format which I gather is intended
for use with Windows Media Player, but I can't get
WMP on a Mac to play it. What I want to do is use these
files in iMovie. mplayer and vlc will play them, but
I can't get mencoder to convert them to anything
that iMovie can use.

I reported the problem to a vlc forum a while ago:

To: vlc at videolan dot org
      * Subject: trouble converting ASF from Traveler camera
      * From: Dan Connolly <connolly at w3 dot org>
      * Date: Wed, 18 May 2005 22:52:13 -0500
http://www.via.ecp.fr/via/ml/vlc/2005-05/msg00241.html
http://people.via.ecp.fr/~admin/20050519-videolan/a20.txt

Today I tried pymedia-1.2.3.0-pre2.tar.gz , but I lose
thusly:

>>> import time, wave, pymedia.audio.sound as sound
> Segmentation fault

I'm using debian sid.

libogg-dev:
  Installed: 1.1.2-1
libvorbis-dev:
  Installed: 1.1.0-1
liblame-dev:
  Installed: 3.96.1-0sarge1

I tried to build from CVS, but I get:

gcc: audio/libavformat/ogg.c: No such file or directory

I took some notes in IRC as I was working on this stuff...
http://www.ilrt.bris.ac.uk/discovery/chatlogs/swig/2005-05-30#T19-50-22


-- 
Dan Connolly, W3C http://www.w3.org/People/Connolly/
D3C2 887B 0F92 6005 C541  0875 0F91 96DE 6E52 C29E
Received on Monday, 30 May 2005 21:28:30 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 22:32:43 UTC