Re: Amaya-9.55-pre3 warnings and X Window error!

On Monday 25 June 2007 05:39, Keith Hopper wrote:
> Greetings,
>      I have been attempting to compile and run the tarball for pre3 without
> success on my new SuSE 10.2 installation with an AMD64x2 processor.
>      During compilation there are literally hundreds of warnings - mainly
> 1.   "dereferencing type-punned pointer will break strict-aliasing rules"
> 2.   "unused variable xxfromxx" - where the characters represented by the
> pairs of xx seem to be non-ISO-8859 characters.
> 3.   "'xxx' may be used uninitialized in this function".
>     Most of these seem to appear in relation to wxWidgets with a few from
> redland and MathML source files.

We'll check in MathML source files as this code is under our control.

>      Despite these many warnings everything seemed to build correctly using
> gcc 4.1.2 20061115!
>      The next thing to do was to try it as suggested in the Unix
> compilation notes by typing - from the directory in which built -
> "bin/amaya"! This doesn't, of course work as the binary is not in its
> installed place!

 The solution is to configure with the option "--prefix=path" where path is 
the parent directory of the Amaya directory.
If you forgot to configure with this option you may edit the script
Amaya/bin/amaya and change the default in this file


>      Knocking up a quick shell script to invoke the real binary, I typed
> "bin/kh &" (for my knocked up script). Using the FVWM window Manager a
> skeleton window came up almost immediately for positioning. When
> positioned, however, as soon as I clicked on the mouse button the upper
> part of an Amaya window appeared - which seemed to have below the button
> bar, etc a left section with some panes in it as far as I could tell from
> the fraction of a second glance I have now seen many times - then Amaya
> crashed with the following X Window error message -
> The program 'amaya-bin' received an X Window system error.
> This probably reflects a bug in the program.
> The error was 'Bad Match (invalid parameter attributes)'
>   (Details: serial 7400 error code 8 request code 143 minor_code 5)
> followed by the usual 'delayed reporting' notice. I would have tried the
> break at gdk_x_error as suggested but gdb said there was no such function -
> I even allowed for delayed loading - the program just ran to termination
> with the same error report.

This problem concerns gtk and not amaya and is specific to these platforms.
The solution is to launch amaya with the script "amaya" or to set the 
environment variable before launching amaya_bin


>      Not knowing the internals of Amaya at all I have the slight suspicion
> that the argument problem is to do with 64-bit register sizes in the
> wxWidgets code.
>      I have available, not yet installed, packages called wxGTK and
> wxGTK-compat version which only contains the run-time libraries
> and files needed by them - although compiled without Unicode support. Might
> it be useful to install these and, if so, would the Amaya build
> automatically make use of them??
>      Sorry about this, but I thought you might like to know before 9.55 is
> formally released!
>                Regards,
>                          Keith

Irène Vatton                     INRIA Rhône-Alpes
INRIA                               ZIRST
e-mail:       655 avenue de l'Europe
Tel.: +33 4 76 61 53 61             Montbonnot
Fax:  +33 4 76 61 52 07             38334 Saint Ismier Cedex - France

Received on Tuesday, 26 June 2007 07:13:43 UTC