Re: Crash after loading of annotations

Irene Vatton wrote:
> On Saturday 09 June 2007 18:15, Urs Holzer wrote:
> > Hello
> >
> > Amaya crashes right after it requests annotations from the server.
> > More precise:
> > [...]
> >
> > This happens on the revision HEAD from the CVS repository. On an older
> > release of amaya, Amaya9.53, loading annotations worked, but Amaya then
> > crashed on the _next_ request to a server it made.
> >
> > I am running Debian Linux 4.0 (i.e. the stable distribution etch) on an
> > x86 machine.
> >
> > As I am not familiar with debuggin C applications, please tell me how I
> > can help locating the problem. I ran Amaya under strace, here is the last
> > part of the trace, perhaps it helps you:
> > [...]
> I guess this bug is fixed by the patch suggested by Yusuke Ishii

Indeed, it is. Unfortunately, Amaya crashes now on the next request, like 
Amaya9.53 did. This might be unrelated to the bug found by Yusuke Ishii.

The following happens: Initially, everything works fine. Then I load 
annotations, which also works. But after that, the next http-request (hitting 
the reload button, selecting a link, loading annotations a second time) 
causes a crash:
*** glibc detected *** double free or corruption (!prev): 0x0a57e010 ***
*** Amaya: Irrecoverable error ***Aborted
or sometimes simply indicating a segmentation fault.


Received on Thursday, 21 June 2007 10:37:28 UTC