Re: bug-reports amaya 8.51 and 9.51

Am Thursday 08 June 2006 14:54, sprach Regis Boudin:
> This is because the Debian package is built using the shared redland and
> wxWidgets libraries insted of the static ones.

The thing with the dynamic libraries explains a lot of things.
> > following error: gtk-CRITICAL **: gtk_widget_set_colormap: assertion
> > `!GTK_WIDGET_REALIZED (widget)' failed
> Well, this is probably a bug in the Mesa/X/ati DRI driver, according to
> one of the Mesa maintainers for Debian.
As the static version from W3-server works, I would say that the issue is 
somewhere in the shared libraries.

> > I did a aptitude remove amaya and it de-installed all the packages above.
> > I
> > installed amaya 9.5 and everything worked.
> Where did you get this one from ?

Normally I only install amaya versions from the w3-server, because the update 
in debian wasn't that fast. I was pleased and surprised to find amaya 9.51 in 
the debian repository. I keep an archive of old amaya-versions, so I have 
easily made some dpkg -i on an older version. 
> > I then installed amaya_wx-9.51-1_i386.deb from
> >
> > everything still worked.
> Ok, now it's getting really strange. I tried to install this one, and I
> got the same error as with the one from unstable.

Have you removed all the other first and reset your .amaya directory?
> > I re-installed amaya from the debian repository including all the
> > packages above, removed only the amaya package and installed the version
> > from the W3C server. It worked.
> Now, I don't understand things anymore. It doesn't work for me. Maybe
> because I didn't have the DRI enable when I tested yesterday evening.

I have DRI enabled, but even the remote scenario I described below worked with 
the statically linked version (softGL). I also have the latest clean sid with 
> It's slightly more complicated. The Debian one is linked against the
> shared libGL and libGLU, rather than the one provided in the source
> tarball. The problem is, there seem to be a bug somewhere in wxWidgets
> and/or Mesa, though I haven't managed to find where exactly.
> Before someone asks, I tried to build with static wxWidgets and Mesa from
> the source, and I still had the error.

Issue is that all the wxWidget-things (menus and icons and frames) displayed 
very well. Only the rendering of the page was messy. So it hints to a problem 
between the amaya rendering output and what the GL-thing expects...
> Apparently, running Amaya from a distant machine has always been a problem
> on Debian, which I haven't had much time to actually look at so far.

I work like that since ages and it worked with the GTK-version, but it has 
performance issues with the WX version. If it doesn't work, it is caused by 
different font installations on the two debian boxes (debian and fonts 
*sigh*). The WXversion doesn't have the issues with the fonts but is slow 
(means displaying one character per second) to unusable
> What worries me is that you manage to get Amaya working when using the W3C
> package, when I don't doing the same thing.

I think this is because of your thotrc in .amaya which has some 
hardwareacceleration=1 in it like Irene described.

Thanks for the answers..

> Regis

Received on Thursday, 8 June 2006 17:00:10 UTC