Re: bug-reports amaya 8.51 and 9.51

On Thursday 08 June 2006 14:54, Regis Boudin wrote:
> Hi,
> So, since I'm the one maintaining the Debian package, I guess I have to
> answer...
> Rigo Wenning said:
> > I tried to upgrade my amaya 9.5 for various reasons. I had some trouble
> > to install the *.51 versions of amaya on my up to date debian sid
> > (unstable).
> >
> > The W3C package for amaya_gtk-8.8.51-1 is not installable as it requires
> > libpng10-0, which is in "stable" but not installable in "unstable"
> > because of
> > a conflict with gdk-imlib1. "unstable" has libpng12-0.
> For the record, the W3C packages seem to have been built for Sarge.
> However, libpng12-dev is available in Sarge, so I would suggest using it
> instead of libpng10-dev to build the packages.

Yes, I guess we can force the libpng12-0 in the build.

> > The story with amaya 9.51 is a bit more complicated:
> >
> > If I do an aptitude install amaya, it installs amaya_wx-9.51-1 as well as
> > redland-utils, raptor-utils, librdf0, librasqal0, libraptor1,
> > libwxgtk2.6-0
> > and libwxbase2.6-0.
> This is because the Debian package is built using the shared redland and
> wxWidgets libraries insted of the static ones.
> > In the first place, this installed version of amaya did start with the
> > following error: gtk-CRITICAL **: gtk_widget_set_colormap: assertion
> > `!GTK_WIDGET_REALIZED (widget)' failed
> > This let to the fact that the canvas wasn't displayed at all while the
> > menus
> > and the buttons where displayed normally.
> Well, this is probably a bug in the Mesa/X/ati DRI driver, according to
> one of the Mesa maintainers for Debian.

This is exactly the reason why we distribute by default a version with a soft 
GL implementation.

> > I moved the .amaya directory out of the way and it started. This time no
> > error
> > but there was a weird layout as everything was only half visible.

There is probably a link with the following entry in .amaya/thotrc file

> Same problem as before, in fact. The result is a complete mess and changes
> just by resizing the window.
> > I did a aptitude remove amaya and it de-installed all the packages above.
> > I
> > installed amaya 9.5 and everything worked.
> Where did you get this one from ?
> > I then installed amaya_wx-9.51-1_i386.deb from
> >
> > everything still worked.
> Ok, now it's getting really strange. I tried to install this one, and I
> got the same error as with the one from unstable.
> > I re-installed amaya from the debian repository including all the
> > packages above, removed only the amaya package and installed the version
> > from the W3C server. It worked.
> Now, I don't understand things anymore. It doesn't work for me. Maybe
> because I didn't have the DRI enable when I tested yesterday evening.

The version from the W3C server doesn't use shared  redland, wxWidgets, libGL, 
and libGLU libraries.

> > BUT, the difference is that the version from debian repository (sid) is
> > using
> > GL hardware acceleration while the version from the W3C site is only
> > using the soft GL implementation. (at least on my dell d600 with radeon
> > card and xorg 7.0.)
> > So my guess is that the version in the debian repository is somewhat more
> > advanced as it has hardware acceleration, but it is broken in that the
> > display  does not work correctly.
> It's slightly more complicated. The Debian one is linked against the
> shared libGL and libGLU, rather than the one provided in the source
> tarball. The problem is, there seem to be a bug somewhere in wxWidgets
> and/or Mesa, though I haven't managed to find where exactly.
> Before someone asks, I tried to build with static wxWidgets and Mesa from
> the source, and I still had the error.

Did you link with local wxWidgets and Mesa libraries?

> > In my remote setup (ssh into laptop and start amaya there but display on
> > desktop), the amaya from the debian repository crashes with the following
> > comment:
> >
> > (amaya:18003): Gtk-CRITICAL **: gtk_widget_set_colormap: assertion
> > `!GTK_WIDGET_REALIZED (widget)' failed
> > The program 'amaya' received an X Window System error.
> > This probably reflects a bug in the program.
> > The error was 'BadMatch (invalid parameter attributes)'.
> >   (Details: serial 3225 error_code 8 request_code 144 minor_code 5)
> >   (Note to programmers: normally, X errors are reported asynchronously;
> >    that is, you will receive the error a while after causing it.
> >    To debug your program, run it with the --sync command line
> >    option to change this behavior. You can then get a meaningful
> >    backtrace from your debugger if you break on the gdk_x_error()
> > function.)

This is a GTK 1 limitation and then a limitation of the Amaya GTK-version.

> >
> > The amaya 9.51 versions from the W3C site work correctly, but only in
> > soft mode. This is very slow in the described remote setup. That's why I
> > wanted to
> > install the GTK-version that is quick.
> Apparently, running Amaya from a distant machine has always been a problem
> on Debian, which I haven't had much time to actually look at so far.
> What worries me is that you manage to get Amaya working when using the W3C
> package, when I don't doing the same thing.
> Regis

The best would be to have GL hardware implementations fixed.
But meanwhile Rigo, I don't know if it works, you could test if the debian 
package generated by Regis works with GL_ACCELERATED=no in the 
file .amaya/thot.rc
I know that this GL_ACCELERATED variable must be set to "no" on a large set of 
Windows platforms to prevent important troubles.
Irène Vatton                     INRIA Rhône-Alpes
INRIA                               ZIRST
e-mail:       655 avenue de l'Europe
Tel.: +33 4 76 61 53 61             Montbonnot
Fax:  +33 4 76 61 52 07             38334 Saint Ismier Cedex - France

Received on Thursday, 8 June 2006 14:54:56 UTC