bug-reports amaya 8.51 and 9.51

Dear all, 

after some discussions with Laurent Carcone, he encouraged me to send my 
bugreport here...

I tried to upgrade my amaya 9.5 for various reasons. I had some trouble to 
install the *.51 versions of amaya on my up to date debian sid (unstable).

The W3C package for amaya_gtk-8.8.51-1 is not installable as it requires 
libpng10-0, which is in "stable" but not installable in "unstable" because of 
a conflict with gdk-imlib1. "unstable" has libpng12-0. 

The story with amaya 9.51 is a bit more complicated: 

If I do an aptitude install amaya, it installs amaya_wx-9.51-1 as well as 
redland-utils, raptor-utils, librdf0, librasqal0, libraptor1, libwxgtk2.6-0 
and libwxbase2.6-0. 

In the first place, this installed version of amaya did start with the 
following error: gtk-CRITICAL **: gtk_widget_set_colormap: assertion
`!GTK_WIDGET_REALIZED (widget)' failed
This let to the fact that the canvas wasn't displayed at all while the menus 
and the buttons where displayed normally. 

I moved the .amaya directory out of the way and it started. This time no error 
but there was a weird layout as everything was only half visible. 

I did a aptitude remove amaya and it de-installed all the packages above. I 
installed amaya 9.5 and everything worked. 

I then installed amaya_wx-9.51-1_i386.deb from 
everything still worked. 

I re-installed amaya from the debian repository including all the packages 
above, removed only the amaya package and installed the version from the W3C 
server. It worked. 

BUT, the difference is that the version from debian repository (sid) is using 
GL hardware acceleration while the version from the W3C site is only using 
the soft GL implementation. (at least on my dell d600 with radeon card and 
xorg 7.0.)

So my guess is that the version in the debian repository is somewhat more 
advanced as it has hardware acceleration, but it is broken in that the 
display  does not work correctly. 

In my remote setup (ssh into laptop and start amaya there but display on 
desktop), the amaya from the debian repository crashes with the following 

(amaya:18003): Gtk-CRITICAL **: gtk_widget_set_colormap: assertion 
`!GTK_WIDGET_REALIZED (widget)' failed
The program 'amaya' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 3225 error_code 8 request_code 144 minor_code 5)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

The amaya 9.51 versions from the W3C site work correctly, but only in soft 
mode. This is very slow in the described remote setup. That's why I wanted to 
install the GTK-version that is quick. 


Rigo Wenning            W3C/ERCIM
Staff Counsel           Privacy Activity Lead
mail:rigo@w3.org        2004, Routes des Lucioles
http://www.w3.org/      F-06902 Sophia Antipolis

Received on Wednesday, 7 June 2006 17:15:00 UTC