*** Thot: Irrecoverable error ***

I have compiled amaya on a Sun sparc system SunOS 5.5.1 Generic_103640-31
sun4u sparc SUNW,Ultra-Enterprise.
The compilation was not without some probs but I managed to figure those
out. However when I run amaya I get the *** Thot: Irrecoverable error ***.
Running truss against amaya the output ends with:
writev(3, 0xEFFFE110, 2)                        = 2120
open("/usr/lib/X11/XtErrorDB", O_RDONLY)        Err#2 ENOENT
    Incurred fault #6, FLTBOUNDS  %pc = 0xEF323E78
      siginfo: SIGSEGV SEGV_MAPERR addr=0x00002AFE
    Received signal #11, SIGSEGV [caught]
      siginfo: SIGSEGV SEGV_MAPERR addr=0x00002AFE
sigaction(SIGBUS, 0xEFFFD068, 0xEFFFD168)       = 0
sigaction(SIGPIPE, 0xEFFFD068, 0xEFFFD168)      = 0
sigaction(SIGSEGV, 0xEFFFD068, 0xEFFFD168)      = 0
sigaction(SIGABRT, 0xEFFFD068, 0xEFFFD168)      = 0
*** Thot: Irrecoverable error ***write(2, " * * *   T h o t :   I r".., 33)
= 33
lseek(0, 0, SEEK_CUR)                           = 74414
lseek(4, 0, SEEK_CUR)                           = 2528

The file it's trying to open, "/usr/lib/X11/XtErrorDB" doesn't exist, but a
file /usr/lib/X11/XErrorDB (no 't') does! I tried to find in the code where
it references this file so I can change the name and recompile amaya; but
alas, despite searching the entire source I can't find any reference to this
file. I would make a copy of the file but I don't have sufficient
Can you assist please?
David Hollingworth
Motorola Ireland Ltd
Mahon Industrial Estate
Tel. 353 (0)21 511 806
Mbl. 087 419 4614

Received on Wednesday, 26 July 2000 03:44:22 UTC