Amaya 2.4 linux bug

     I have a Compaq Presario 1260 laptop with 160Mbytes of memory and an
18Gbyte hard disc.  At present it dual boots either Windows 2000
Professional or linux 2.2.5-15 (19 April 1999) i586.

     I have both the 'NT' and linux versions of Amaya 2.4.  Amaya works
very happily in the Windows 2000 Professional environment.  The display is
exactly as expected.

     Unfortunately under linux all images, whether jpeg, gif or png are
badly corrupted into 4/5 pixel square blocks (giving a striped effect)
which enable one to vageuly recognise the image (if one knows what it is
supposed to be).

     It is the only program 'common' to both OSs which corrupts images
(mind you it is also true to say that no other program corrupts images
under either OS).

     Having seen some comments on other bugs which may be library related,
the libc in use is version 6 (  I have tried both the tar/zipped
version of 2.4 for linux and, in case the archive was corrupted, also the
rpm version.  There is no difference. The problem also appears to be
independent of which window manager is in use.

     I have even tried to compile the source, but could not for lack of an
Xm (?) library. Could this be related to the problem??  Amaya does not,
however, complain about anything being missing!

       Keith Hopper

City Desk
Waikato University
[PGP key available if desired]

Received on Friday, 31 March 2000 02:24:02 UTC