W3C home > Mailing lists > Public > www-amaya@w3.org > January to March 1999

Re: Amaya does not work with the network

From: <jose.kahan@w3.org>
Date: Fri, 12 Feb 1999 16:12:30 +0100 (MET)
Message-Id: <199902121512.QAA12172@tuvalu.inrialpes.fr>
To: Joerg.Wittenberger@pobox.com
Cc: www-amaya@w3.org
Hello Jerry,

In our previous episode, Joerg Wittenberger said:
> Hello Jose,
> I do not using any proxies.  I'm actually a bit experienced concering
> networks (with the exception of socks, which in turn is what is used
> here); that why I said, I'm sorry to be that unspecific and now I'm
> even more sorry not to have made that clear.

Ah, but you now gave this SOCKS piece of information. Amaya doesn't
have built-in SOCKS support. To add it, you need to recompile the source
code. Specifically, you have to configure libwww (the network library
we use in Amaya) to say you're using SOCKS. 

I know that people have done it in the past. I'm not sure if it still
works as Henrik, the author of libwww, hasn't tested since some time

Here's more info on how to compile libww in this mode (I'll add this to
the FAQ):


Note that the libwww directory is now called libwww, and not w3c-libwww-5.0a.

> The thing is, that I try to work just at my own machine, that is
> apache and amaya are at the very same machine.  As it is a laptop, the 
> network is not always reachable - which I was suspecting o be the
> reason at first.

> What I tried was to access apache via localhost, the hostname without
> domain (see network, it's not always resolvable) and via full
> qualified host name. The log files do not show any connection
> attempts, not even at tcp level let alone the apache.  To make sure
> it's not just a matter of the resolver, I activated and deactivated
> the dns server.  What I could not figure was, whether there is still
> an option to be put into /etc/resolv.conf to tell use /etc/hosts and
> dns in this or that sequence.  The docs don't have such an option - I
> merly remember that there was one in the past - but things might
> change and memory might cheat.

If this can be of help, under Linux,

My /etc/hosts has:

# Internet host table
#       localhost
my.ip.address   mymachine-name.my-domain.fr     mymmachine-name

My /etc/resolv.conf has:

search my-domain.fr
nameserver dns.ip.address

My /etc/hosts.conf has:

order hosts,bind
multi on

> There is a second web server in the intranet.  Netscape et al can
> reach it without any proxies or difficulties.  Amaya does not talk to
> it either.

This may be related to the socks problem.

> jk> If this doesn't work yet, please email us the URL you're trying to
> jk> access so that we can analyze the problem from here.
> http://localhost/
> http://gliep/
> http://server.domain.intranet/
> ;-) guess there is no chance in any way.

This was interesting. I tried all of the above cases (just changing the
domain name and machine name) under Linux and Solaris and it works well.

I found a problem while running Amaya as root and trying to access
http://localhost/. I could browse that URL the first time, but couldn't
do it again from the same session.  I suspect this is a problem concerning
the cache and the access rights. As a non-root user, it works all the time.

If you still have problems, I'll give you some instructions on how to
generate a debug trace.

Thanks for your patience!

Received on Friday, 12 February 1999 10:12:37 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 22:30:27 UTC