W3C home > Mailing lists > Public > spec-prod@w3.org > January to March 2016

Re: ReSpec broken on Safari?

From: Marcos Caceres <w3c@marcosc.com>
Date: Mon, 15 Feb 2016 17:44:13 +1100
To: Gregg Kellogg <gregg@greggkellogg.net>
Cc: spec-prod@w3.org, Michiel Bijl <michiel@agosto.nl>
Message-ID: <etPan.56c173bd.70698b32.227@Zero-privacy.local>
Hi Greg, All,
Apologies, top-post..

Can I kindly ask that folks please file ReSpec bugs here:
https://github.com/w3c/respec/issues

I've filed this for you:
https://github.com/w3c/respec/issues/562

Remember, if you find a bug in ReSpec, just click on the "ReSpec pill" > "About ReSpec" > click on the link to file a bug.

That keeps this list free of particular product bug discussions, etc.

Many thanks!  


On February 12, 2016 at 4:52:07 AM, Michiel Bijl (michiel@agosto.nl) wrote:
> Which version of Safari did you use to test?
>  
> I don’t get the errors reported by you in version version 9.0.3 (10601.4.4).
>  
> —Michiel
>  
> > On 11 Feb 2016, at 18:44, Gregg Kellogg wrote:
> >
> > I’ve just started seen errors pop up when running on Safari:
> >
> > • [TypeError] undefined is not an object (evaluating 't[0].for_') ⊟
> > https://www.w3.org/Tools/respec/respec-w3c-common:14:24272
> > each@https://www.w3.org/Tools/respec/respec-w3c-common:5:27677
> > each@https://www.w3.org/Tools/respec/respec-w3c-common:5:25651
> > run@https://www.w3.org/Tools/respec/respec-w3c-common:14:23658
> > https://www.w3.org/Tools/respec/respec-w3c-common:8:7646
> > initializePromise@[native code]
> > Promise@[native code]
> > https://www.w3.org/Tools/respec/respec-w3c-common:8:7617
> > promiseReactionJob@[native code]
> >
> > This happens, for example, on http://w3c.github.io/csvw/primer/.
> >
> > No errors on Firefox or Chrome.
> >
> > Gregg Kellogg
> > gregg@greggkellogg.net
> >
> >
>  
>  
Received on Monday, 15 February 2016 06:44:51 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:55:21 UTC