Naming of p:declare-step


I'm really sorry to bring this up, and if people shout at me I'll go 
away, but it just struck me that now that p:declare-step has such 
prominence now we really ought to give it a better name.

In XSLT, we don't have <xsl:declare-template> or 
<xsl:declare-decimal-format>, we have <xsl:template> and 
<xsl:decimal-format>. In XSD, we don't have <xs:defineComplexType> or 
<xs:declareElement>, we have <xs:complexType> and <xs:element>.

So let's rename <p:declare-step> as p:step or p:step-type or p:step-kind 
-- the important thing is what we're declaring, not the fact that we're 
declaring it.


Jeni Tennison

Received on Thursday, 14 February 2008 12:52:11 UTC