W3C home > Mailing lists > Public > public-xml-processing-model-comments@w3.org > November 2008

Re: [Newbie] Pipeline to store the input file fails; what am I doing wrong please?

From: Costello, Roger L. <costello@mitre.org>
Date: Tue, 11 Nov 2008 11:02:50 -0500
Message-ID: <B8415163A689094689542C617ECA0366032F55AA@IMCSRV5.MITRE.ORG>
To: <public-xml-processing-model-comments@w3.org>


Thanks Norm. Per your suggestion, I upgraded to the latest version
(9.1.0.3) of Saxon-SA and now it works.

/Roger


"Costello, Roger L." <costello@mitre.org> writes:
> What am I doing wrong please? 

Nothing, as far as I can tell. And that pipeline runs fine for me.

> Error message I get using Calabash 0.8.5:
>
> xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
> Error  : Pipeline failed: 
> com.xmlcalabash.core.XProcException:
> net.sf.saxon.s9api.SaxonApiException: 
>
> Supplied XPathVariable is bound to the wrong slot: 
> Perhaps it was created using a different static context
>
> com.xmlcalabash.core.XProcException: 
> net.sf.saxon.s9api.SaxonApiException: 
>
> Supplied XPathVariable is bound to the wrong slot: perhaps it was
> created using a different static context
>         at
>
com.xmlcalabash.runtime.XAtomicStep.evaluateXPath(XAtomicStep.java:560)
> ...
> xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

What version of Saxon are you using, and is it possible that you've
got two versions on your classpath, perhaps, for example, different
versions of SaxonB and SaxonSA?

                                        Be seeing you,
                                          norm
Received on Tuesday, 11 November 2008 16:03:58 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:41:08 UTC