W3C home > Mailing lists > Public > public-ws-desc-comments@w3.org > September 2004

FW:LC11 [was LC10: element names for defaults]

From: Jonathan Marsh <jmarsh@microsoft.com>
Date: Thu, 9 Sep 2004 12:19:03 -0700
Message-ID: <DF1BAFBC28DF694A823C9A8400E71EA204D11343@RED-MSG-30.redmond.corp.microsoft.com>
To: "Hugo Haas" <hugo@w3.org>
Cc: <public-ws-desc-comments@w3.org>

For the record, the Working Group resolved this issue (LC11 [1]) by
agreeing on the naming convention fooDefault, specifically renaming
@whttp:defaultTransferCoding to @whttp:transferCodingDefault.   We will
assume you accept this resolution if we don't receive an explicit
acknowledgement by 1 October.

[1] http://www.w3.org/2002/ws/desc/4/lc-issues/#LC1

-----Original Message-----
From: www-ws-desc-request@w3.org [mailto:www-ws-desc-request@w3.org] On
Behalf Of Hugo Haas
Sent: Thursday, September 09, 2004 3:12 AM
To: www-ws-desc@w3.org
Subject: LC10: element names for defaults


In preparation for discussing LC10 in today's call, I have noticed
that we are inconsistent in our naming of elements for default values.

Frank Ellerman points out at [1]:

> In 3,2 you say "whttp:methodDefault", but later you use
> "whttp:defaultMethod" (3.3 and 3.5.3).

Putting this one aside, we also have:
- wsoap:mepDefault
- whttp:defaultTransferCoding

I guess that the typo Frank is reporting reflects this lack of
consistency. It would be good if we were using the same convention in
all the bindings: wbinding:fooDefault or wbinding:defaultFoo. I have a
very slight preference for the former FWIW.



Hugo Haas - W3C
mailto:hugo@w3.org - http://www.w3.org/People/Hugo/
Received on Thursday, 9 September 2004 19:19:34 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:31:00 UTC