W3C home > Mailing lists > Public > whatwg@whatwg.org > July 2015

Re: [whatwg] DOM Events Proposal: EventListenerOptions 'mayCancel' for improved scroll performance

From: Domenic Denicola <d@domenic.me>
Date: Thu, 9 Jul 2015 16:50:50 +0000
To: Rick Byers <rbyers@chromium.org>, Philip J├Ągenstedt <philipj@opera.com>
Message-ID: <CY1PR0501MB1369754B9CE24355B5999974DF900@CY1PR0501MB1369.namprd05.prod.outlook.com>
Cc: WHATWG <whatwg@whatwg.org>, James Ross <w3c-20040125@james-ross.co.uk>
From: whatwg [mailto:whatwg-bounces@lists.whatwg.org] On Behalf Of Rick Byers

> That seems like a nice incremental compromise.  Using a new name for addEventListener will help address some of the feature detection / compatiblity concerns too.  Filed https://github.com/RByers/EventListenerOptions/issues/18.


I tend to disagree. I think we shouldn't "use up" the nice names like off and on without significant thought as to what a well-designed better-EventTarget would look like. And I think that such thought would take time and motivation which we should not block this proposal on.

The idea of extending addEventListener seems like the most reasonable thing to me. If someone wants to take on the larger project of EventTarget overhaul, that should be done in a more deliberate fashion.
Received on Thursday, 9 July 2015 16:51:18 UTC

This archive was generated by hypermail 2.3.1 : Thursday, 9 July 2015 16:51:19 UTC