W3C home > Mailing lists > Public > whatwg@whatwg.org > October 2012

Re: [whatwg] [canvas] Path object

From: Tab Atkins Jr. <jackalmage@gmail.com>
Date: Tue, 2 Oct 2012 15:00:29 -0700
Message-ID: <CAAWBYDDaMCCXu9FL77iG1nystKY+ZJm56bhho-5otugMi+KpuQ@mail.gmail.com>
To: Elliott Sprehn <esprehn@gmail.com>
Cc: WHATWG <whatwg@whatwg.org>
On Sat, Sep 22, 2012 at 9:17 PM, Elliott Sprehn <esprehn@gmail.com> wrote:
> I was looking at the canvas Path API and had some concerns. In
> particular it's inconsistent with the rest of canvas:
> We already have CanvasGradient and CanvasPattern in the global
> namespace, so this should probably be called CanvasPath.
> We also have createLinearGradient() and createPattern(), but this new
> thing is "new Path".
> Could we get some consistency here? Like adding new CanvasGradient()
> (or a createPath() method) to match up with Path and renaming this
> thing CanvasPath?

I think the SVGWG would be opposed to that - we rather like the Path
api and would appreciate being able to appropriate it for our own uses
(merging with the <path> API).

I'm fine with gradients/patterns moving to a plain constructor rather
than a factory method, though.

Received on Tuesday, 2 October 2012 22:02:02 UTC

This archive was generated by hypermail 2.4.0 : Wednesday, 22 January 2020 16:59:46 UTC