W3C home > Mailing lists > Public > whatwg@whatwg.org > September 2011

[whatwg] Fixing undo on the Web - UndoManager and Transaction

From: Ryosuke Niwa <rniwa@webkit.org>
Date: Sun, 11 Sep 2011 19:00:21 -0700
Message-ID: <CABNRm62dcHThsKJMm-86kLO72FGG0xRUhgt49gCY-q3Cqv3ETA@mail.gmail.com>
On Tue, Aug 30, 2011 at 12:15 PM, Ryosuke Niwa <rniwa at webkit.org> wrote:
> 4. Jonas requested that we have manualTransact and managedTransact instead
> of single transact on undoManager for clarity.  I think this is a good idea
> but I'd rather settle the naming issue first.

 If we're making this change (presumably, automaticTransact and
manualTransact), then it seems odd that both of them take the Transaction
interface because "apply" is required while "unapply" and "reapply" are
ignored for automaticTransact, but they're all optional for manualTransact.

Should we also split the interface into AutomaticTransaction interface and
ManualTransaction interface?

- Ryosuke
Received on Sunday, 11 September 2011 19:00:21 UTC

This archive was generated by hypermail 2.4.0 : Wednesday, 22 January 2020 16:59:36 UTC