[whatwg] [html5] r5307 - [giow] (0) use vendor--feature instead of _vendor-feature since Apple engineers [...]

On Wed, 1 Dec 2010, Anne van Kesteren wrote:
> On Wed, 01 Dec 2010 00:27:23 +0100, Ian Hickson <ian at hixie.ch> wrote:
> > An update since this topic was discussed on this list before:
> > 
> > I updated the vendor-specific syntax a while back to be 
> > x-vendor-foo="" for content attributes, and .vendorFoo for IDL 
> > members; attributes starting with an underscore are also reserved but 
> > their use is not encouraged.
> If we do .vendorFoo shouldn't we just do vendor-foo=""? "opera", "moz", 
> "webkit", "ms" are unique enough and HTML attributes generally do not 
> use hyphens anyway. (And yes, there will be some more vendors, etc. But 
> over the years there have not been many extensions at all so this is all 
> rather manageable.)

I think we want a prefix, in general. The problem is that it is not 
aesthetically pleasing to have a prefix for IDL attributes, unlike 
content attributes where it doesn't look anywhere near as bad. Hence where 
we are now, which seems fine.

Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'

Received on Tuesday, 1 March 2011 15:24:07 UTC