W3C home > Mailing lists > Public > whatwg@whatwg.org > February 2010

[whatwg] Adding FormData support to <form>

From: Michael A. Puls II <shadow2531@gmail.com>
Date: Thu, 18 Feb 2010 21:59:40 -0500
Message-ID: <op.u8cs9p1t1ejg13@sandra-svwliu01>
On Thu, 18 Feb 2010 21:20:38 -0500, Jonas Sicking <jonas at sicking.cc> wrote:

> On Thu, Feb 18, 2010 at 5:30 PM, Robert O'Callahan  
> <robert at ocallahan.org> wrote:
>> On Fri, Feb 19, 2010 at 1:52 PM, Ian Hickson <ian at hixie.ch> wrote:
>>>
>>> toDataURL() was named that way for consistency with toString(), which
>>> seems a closer analogue here than getElementById() and friends.
>>
>> <bikeshed>
>> But you're not really converting the form element into something  
>> equivalent,
>> are you? That's what "to" methods usually imply, IMHO. Maybe it should  
>> be
>> "createFormData" or "extractFormData"?
>> </bikeshed>
>
> This was my reasoning too.
>
> I'm not a big fan of 'createFormData' as to me it doesn't sound like
> it'll also populate the FormData with the current values. Possibly due
> to the similarity with 'createElement'. 'extractFormData' sounds ok
> though, though i think 'getFormData' is nicer due to its shorter name.

A while ago, I mentioned this  
<http://lists.whatwg.org/htdig.cgi/whatwg-whatwg.org/2009-January/018097.html>  
as getFormData(). I still like that name.

-- 
Michael
Received on Thursday, 18 February 2010 18:59:40 UTC

This archive was generated by hypermail 2.4.0 : Wednesday, 22 January 2020 16:59:21 UTC