W3C home > Mailing lists > Public > whatwg@whatwg.org > August 2007

[whatwg] [WA1] Audio and relative URIs

From: Ian Hickson <ian@hixie.ch>
Date: Sat, 4 Aug 2007 00:49:41 +0000 (UTC)
Message-ID: <Pine.LNX.4.64.0708040048030.25485@dhalsim.dreamhost.com>
On Tue, 19 Jul 2005, Christian Biesinger wrote:
> 
> the section on Audio, http://whatwg.org/specs/web-apps/current-work/#sound,
> says:
> > The Audio() constructor takes a single argument, a URI (or IRI), which
> > is resolved using the script context's window.location.href
> 
> Does this mean that a possible <base href> should indeed be ignored here?

This has been redefined in a way that makes the URL resolution hopefully 
more defined (as defined, at least, as the resolution of the URL in any 
other attribute in an element that isn't in the tree).


> > and if two identical clips are started with a two second interval then 
> > when the sound is reenabled they must still be two seconds out of 
> > sync.
> 
> I'm not sure that's easily implementable...

Why not? (Note, though, that this requirement is no longer there.)


> If the sound is disabled for five seconds after the start of a sound and 
> then enabled, does the clip have to start playing at the fifth second?

This is now defined in far more detail.

Let me know if the current spec still has issues.

Cheers,
-- 
Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'
Received on Friday, 3 August 2007 17:49:41 UTC

This archive was generated by hypermail 2.3.1 : Monday, 13 April 2015 23:08:36 UTC