W3C home > Mailing lists > Public > whatwg@whatwg.org > April 2007

[whatwg] Apple Proposal for Timed Media Elements

From: Michael A. Puls II <shadow2531@gmail.com>
Date: Thu, 5 Apr 2007 14:08:31 -0400
Message-ID: <6b9c91b20704051108y227ed4d1i62a7ead83c5b4f92@mail.gmail.com>
On 4/5/07, Vladimir Vukicevic <vladimir at pobox.com> wrote:
> Maciej Stachowiak wrote:
> >
> > On Apr 4, 2007, at 7:31 PM, Vladimir Vukicevic wrote:
> >> 1. 'media-loop-count' is an awkward name, especially with "The default
> >> value of 1 means the item will play through once but will not loop."
> >> We went through this with APNG, and ended up renaming that member.  I
> >> would suggest 'media-play-count' instead -- that way there is no
> >> ambiguity with what the number means.
> >
> > We considered 'media-repeat-count' instead of 'media-loop-count', but
> > that turned out to be more confusing. We really wanted all the
> > looping-related properties to have consistent naming, and I don't think
> > 'play' would work in the other places mentioned.
> The problem is that 'media-loop-count' with a value of 1, as defined,
> doesn't have anything to do with looping... play-count is much more
> descriptive of its actual purpose, IMO, despite not containing 'loop' in
> the name.  The others should definitely stay "loop-", though.

I agree.

To me, a loop-count of 1 means that it will play once and then loop
once. If a loop-count of 1 means that it only plays once, then it's
not really a loop-count. It's a play-count.

I myself like how the Windows Media 6.4 API does it. It has a
PlayCount  that specifies how many times to play, but 0 is a valid
value that means to repeat forever.

Received on Thursday, 5 April 2007 11:08:31 UTC

This archive was generated by hypermail 2.4.0 : Wednesday, 22 January 2020 16:58:54 UTC