W3C home > Mailing lists > Public > public-webrtc@w3.org > June 2015

Re: PR for adding RtpSender.transport, RtpReceiver.transport, RTCDtlsTransport, RTCIceTransport, etc

From: Silvia Pfeiffer <silviapfeiffer1@gmail.com>
Date: Sun, 21 Jun 2015 10:05:17 +1000
Message-ID: <CAHp8n2mLg1nbMQS83H7qxdJ_s49_WVVYwk7jfcKdMgNRq_omEA@mail.gmail.com>
To: Bernard Aboba <Bernard.Aboba@microsoft.com>
Cc: Harald Alvestrand <harald@alvestrand.no>, "public-webrtc@w3.org" <public-webrtc@w3.org>
On Sun, Jun 21, 2015 at 6:41 AM, Bernard Aboba
<Bernard.Aboba@microsoft.com> wrote:
> On Jun 20, 2015, at 5:49 AM, Harald Alvestrand <harald@alvestrand.no> wrote:
>> The names should at least be correlated - as editor of the stats specification, I'm probably not the right one to decide which spec to suggest changes in; I'm too enamored of my own prose :-)
> [BA] Yes, please!
> We actually have 3 sets of object names with slight differences - WebRTC 1.0, Stats API and ORTC. Having to track these different names for what appear to be the same things is quite painful.  For example, it is RTCDTMFSender in WebRTC 1.0 and RTCDtmfSender in ORTC.

FWIW I find RTCDtmfSender more readable.

Received on Sunday, 21 June 2015 00:06:08 UTC

This archive was generated by hypermail 2.3.1 : Monday, 23 October 2017 15:19:44 UTC