Re: Mozilla/Cisco API Proposal

Ian Hickson wrote:
> I'm not sure the "addLocalStream()" change is better either; after all,
> it's quite possible to add a remote stream, e.g. to send the stream onto
> yet another user. Maybe addSendingStream() or just sendStream() and
> stopSendingStream() would be clearer?
> (I should clarify that I have no strong opinion on any of these naming
> issues. If anyone feels strongly about one name or another, I'm happy to
> change the spec to match whatever is preferred.)

The reason I suggested the addLocalStream vs. onRemoteStreamAdded change 
was that with just addstream and onstreamadded, it wasn't clear (on my 
brief initial read) that calling the former wouldn't cause the latter to 
fire... it was only when reading the example code that it became clear 
the add/remove methods were talking about very different streams than 
the added/removed events. I suggested using Local and Remote to 
differentiate them just to match the localStreams and remoteStreams lists.

Received on Tuesday, 12 July 2011 10:00:23 UTC