Re: [webrtc-stats] RTCMediaStreamTrackStats is four dictionaries in one

@henbos I'm not proposing replacing `kind` with a unique type. Dictionaries don't have JS-observable types, so refactoring into 4 dictionaries alone is purely editorial, for a more readable spec.

If we don't go for then I'm not proposing removing `remoteSource` either.

If we *do* go for then `remoteSource` disappears naturally (`remoteSource` == `"receiver"`).

I'm hoping we do the latter, since I find it intuitive. That's why I left `remoteSource` out in the examples.

GitHub Notification of comment by jan-ivar
Please view or discuss this issue at using your GitHub account

Received on Tuesday, 12 September 2017 12:27:59 UTC