W3C home > Mailing lists > Public > public-webplatform@w3.org > December 2013

Re: Second JS bulk upload

From: Renoir Boulanger <renoir@w3.org>
Date: Sun, 1 Dec 2013 14:33:09 -0500
Cc: List WebPlatform public <public-webplatform@w3.org>
Message-Id: <33801C16-16B0-4928-86AB-13D7BAE8B039@w3.org>
To: Max Polk <maxpolk@gmail.com>

Let me give it a shot. 

It might be shooting the obvious, but let’s make urls as short but meaningful.


On Dec 1, 2013, at 2:19 PM, Max Polk <maxpolk@gmail.com> wrote:

> On Mon, Nov 25, 2013 at 1:45 PM, Julee <julee@adobe.com> wrote:
> Hi, Max & All:
> We also have the convention that the URL should be lowercase, except for
> the language elements, which should conform to the spec.
> Need suggestions below.
> Page renames per Julee:
>   javascript/Objects      javascript/objects
>   javascript/Constants    javascript/constants
>   javascript/Properties   javascript/properties
>   javascript/Functions    javascript/functions
>   javascript/Methods      javascript/methods
>   javascript/Operators    javascript/operators
>   javascript/Operators/*  javascript/operators/* (all subpages)
> Not modified, unless someone has a better suggestion:
>   javascript/JavaScript Reference      "JavaScript Reference” capitalized


>   javascript/Math/Math Constants       "Math Constants” capitalized


>   javascript/Number/Number Constants   (same)


>   javascript/RegExp/1 9 Properties     "Properties” capitalized


> Not modified, unless someone has a better suggestion.  The following are language elements that are ideas and are not named:
>     javascript/Regular Expression        (note: different than Regex)
>     javascript/operators/Addition Assignment
>     javascript/operators/Addition
>     javascript/operators/Assignment
>     javascript/operators/Bitwise AND Assignment
>     javascript/operators/Bitwise AND
>     javascript/operators/Bitwise Left Shift
>     javascript/operators/Bitwise NOT
>     javascript/operators/Bitwise OR Assignment
>     javascript/operators/Bitwise OR
>     javascript/operators/Bitwise Right Shift
>     javascript/operators/Bitwise XOR Assignment
>     javascript/operators/Bitwise XOR

Are we going to have one page per operators?

At MDN, here is how they do it https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Operators/Bitwise_Operators

I guess the matter is if we concatenate pages, right?

>     javascript/operators/Comma
>     javascript/operators/Comparison
>     javascript/operators/Compound Assignment
>     javascript/operators/Conditional Ternary
>     javascript/operators/delete
>     javascript/operators/Division Assignment
>     javascript/operators/Division
>     javascript/operators/in
>     javascript/operators/Increment and Decrement
>     javascript/operators/instanceof
>     javascript/operators/Left Shift Assignment
>     javascript/operators/Logical AND
>     javascript/operators/Logical NOT
>     javascript/operators/Logical OR
>     javascript/operators/Modulus Assignment
>     javascript/operators/Modulus
>     javascript/operators/Multiplication Assignment
>     javascript/operators/Multiplication
>     javascript/operators/new
>     javascript/operators/Right Shift Assignment
>     javascript/operators/Subtraction Assignment
>     javascript/operators/Subtraction
>     javascript/operators/typeof
>     javascript/operators/Unsigned Right Shift Assignment
>     javascript/operators/Unsigned Right Shift
>     javascript/operators/void
> For all but the first above, the parent javascript/operators is fixed, but these are multiword page names, where the *lower*-case page names are JavaScript language elements (delete, in, new, typeof, void) and the upper-case page names are descriptions of the operator (to differentiate between language element and non-language element in the *reverse* sense of using case).  Whereas javascript/Math is a Math object, a javascript/operators/Division is really a "/" which is unusable as a page name, so a descriptive word "Division" is used instead.
> Perhaps under operators we don't want to lower-case everything like this:
>     javascript/operators/subtraction
>     javascript/operators/typeof
>     javascript/operators/unsigned right shift assignment
>     javascript/operators/unsigned right shift
>     javascript/operators/void
> because the above strategy makes typeof and void (actual operators) indistinguishable from words used to describe the operators (subtraction and unsigned right shift).  Maybe that doesn't matter though since people can just read the page.

You got a point there. So Capitalize words that is either standardized (e.g. RegExp) AND the ones that cannot be in a URL and has to be put as word; such as -/&<>|, (and so on).

Received on Sunday, 1 December 2013 19:33:12 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:13:57 UTC