W3C home > Mailing lists > Public > public-webpayments@w3.org > May 2015

Re: Security Vocabulary naming mis-match

From: Dave Longley <dlongley@digitalbazaar.com>
Date: Fri, 01 May 2015 14:57:52 -0400
Message-ID: <5543CCB0.40306@digitalbazaar.com>
To: Brooks Boyd <boydb@midnightdesign.ws>, public-webpayments@w3.org
Thanks, Brooks. The draft has been updated to better match the JSON-LD 
context. That draft is in need of attention in general, so there may be 
other issues -- we just haven't had the spare cycles to clean it up or 
bring it and a few other related draft specs [1][2] in line with one 
another.

[1] https://web-payments.org/specs/source/secure-messaging/
[2] https://web-payments.org/specs/source/ld-signatures/

On 04/22/2015 10:46 AM, Brooks Boyd wrote:
> As I was perusing and attempting implementation of the Security 
> Vocabulary draft, I ran into an issue with the "data" property of an 
> "EncryptedMessage" class:
>
> https://web-payments.org/specs/source/vocabs/security.html#data
>
> The draft document indicates "data" should be the property to hold an 
> EncryptedMessage's encrypted payload, while "cipherAlgorithm" holds 
> the name of the encryption used. However, the JSON-LD context document 
> hosted at https://w3id.org/security/v1 has no "data" element, though 
> it has a "cipherData" element that seems to fit the naming scheme 
> alongside "cipherAlgorithm".
>
> One of the two should probably be updated, since putting the example 
> cited in the draft document under the "data" property into the JSON-LD 
> playground (http://tinyurl.com/p2gdacw) skips over the "data" element 
> as unrecognized.
>
> Brooks


-- 
Dave Longley
CTO
Digital Bazaar, Inc.
http://digitalbazaar.com
Received on Friday, 1 May 2015 18:58:15 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:07:40 UTC