Security Vocabulary naming mis-match

As I was perusing and attempting implementation of the Security Vocabulary
draft, I ran into an issue with the "data" property of an
"EncryptedMessage" class:

The draft document indicates "data" should be the property to hold an
EncryptedMessage's encrypted payload, while "cipherAlgorithm" holds the
name of the encryption used. However, the JSON-LD context document hosted
at has no "data" element, though it has a
"cipherData" element that seems to fit the naming scheme alongside

One of the two should probably be updated, since putting the example cited
in the draft document under the "data" property into the JSON-LD playground
( skips over the "data" element as unrecognized.


Received on Thursday, 23 April 2015 07:50:55 UTC