Re: JS code examples for ACTION 43

On Thu, Sep 6, 2012 at 10:29 AM, Ryan Sleevi <sleevi@google.com> wrote:
>
> I would suggest rather than having onProgress, we'd rename it to some
> event that is suitably ambiguous as to whether data resuled.
> onProcessed() perhaps?

If I understand it correctly, onProcessed() tells an application when
the next processData() call or the complete() call can be invoked on
the CryptoOperation object.

For an application that cares about the availability of more output in
|result|, it seems that onProgress() is still useful. Otherwise the
application will need to remember the old state of |result| in order
to detect more output has become available. Note that the complete()
method also causes the |progress| event to be fired, which seems to be
another reason onProcessed() cannot replace onProgress().

Wan-Teh

Received on Friday, 7 September 2012 01:51:01 UTC