Re: [webauthn] PRF inputs should be BufferSource instead of ArrayBuffer (#1851)

I don't think it's worth splitting the IDL just for the output. That causes additional code size in browsers too because an extra object needs to be supported.

`BufferSource` isn't a real type, it's just means either `ArrayBuffer` or `ArrayBufferView`. For inputs that has real benefits as you not, but on the output it doesn't really make any difference because the underlying object will still be an `ArrayBuffer`. E.g.:

> > temp1.getClientExtensionResults().prf.results.first instanceof ArrayBuffer
> > true

-- 
GitHub Notification of comment by agl
Please view or discuss this issue at https://github.com/w3c/webauthn/issues/1851#issuecomment-1430089898 using your GitHub account


-- 
Sent via github-notify-ml as configured in https://github.com/w3c/github-notify-ml-config

Received on Tuesday, 14 February 2023 17:08:53 UTC