Re: [webauthn] Replace AuthenticationExtensionsAuthenticatorInputs with CDDL (#1440)

Thanks @selfissued - I've renamed the `extensionInputs` type to `AuthenticationExtensionsAuthenticatorInputs`, and `extensionOutputs` to `...AuthenticatorOutputs` rather than `AuthenticationExtensionsClientOutputs` since the latter still remains as a different WebIDL type. The group sockets are still named `$$extensionInput` and `$$extensionOutput`, though - would you like me to rename them to `AuthenticationExtensionsAuthenticatorInput` and `...Output` (singular) also?

I also took the opportunity to add some more cross-references and explicitly spell out to use the extension ID as the entry key for the group plugs.

GitHub Notification of comment by emlun
Please view or discuss this issue at using your GitHub account

Received on Thursday, 25 June 2020 14:28:37 UTC