W3C home > Mailing lists > Public > public-webapps@w3.org > April to June 2014

Re: [editing] Leading with ContentEditable=Minimal

From: Julie Parent <jparent@google.com>
Date: Mon, 23 Jun 2014 09:25:56 -0700
Message-ID: <CAPSmAASS+Ng6Rvfc9t+EnWw5wHMx+OmsiqwV7ATrp4WcLM3qng@mail.gmail.com>
To: Robin Berjon <robin@w3.org>
Cc: "public-webapps@w3.org" <public-webapps@w3.org>, public-editing-tf@w3.org
Well stated.  I like contentEditable=cursor.


On Mon, Jun 23, 2014 at 9:21 AM, Robin Berjon <robin@w3.org> wrote:

> On 17/06/2014 02:12 , Julie Parent wrote:
>
>> If Intention events are (temporarily) moved out of scope, I think this
>> leads us back to the question of what would contentEditable='minimal' do
>> exactly?  Enable collapsed selections and default handling of cursor
>> movement ... anything else?  If this is all it would do, then perhaps
>> what we really want is an explicit API to enable cursors?
>>
>
> The way I see it, that is indeed *all* it would do (and serve as a sanity
> flag so that browsers know how to handle this cleanly).
>
> It *is* an explicit API to enable cursors. It has the advantage of reusing
> an existing name so that we don't have to worry about what happens when you
> specify both; and it's declarative because that's what you want for such a
> case (notably so that CSS can style what's editable cleanly).
>
> We could rename it contentEditable=cursor if that's cleaner — the idea is
> the same (and I certainly won't argue bikeshedding :).
>
> --
> Robin Berjon - http://berjon.com/ - @robinberjon
>
Received on Monday, 23 June 2014 16:26:24 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 18:14:25 UTC