W3C home > Mailing lists > Public > public-webapps@w3.org > April to June 2014

Re: Should minimal contentEditable default text input

From: Robin Berjon <robin@w3.org>
Date: Fri, 06 Jun 2014 15:51:57 +0200
Message-ID: <5391C77D.4070104@w3.org>
To: Julie Parent <jparent@gmail.com>
CC: "public-webapps@w3.org" <public-webapps@w3.org>
On 30/05/2014 00:50 , Julie Parent wrote:
> Without default text input, the current proposal for
> contentEditable="minimal" is essentially just enabling cursors (drawing
> them, dispatching events, performing default actions).  Rather than
> calling the mode "minimal", which is ill-defined, why not explicitly
> call it what it is: "cursor-only"?

Sure, but (assuming we go this route) I'm not too worried about the name 
at the moment. We can define what it does, then pick a good name for it. 
That's the easiest bit to change.

>  Or, have contentEditable take a list
> of features to turn enable: contentEditable="enable-cursors
> enable-CommandEvents".

I'd rather we agreed on the pieces we're going to have before we see if 
this can make sense.

> Or, rather than tying this concept to contentEditable, with all the
> assumptions and complications that brings up, why not expose this
> building block as a completely separate attribute?

We can, but this isn't necessarily simpler. Saying we add an "editable" 
attribute, we then have to define what happens when you have <div 
contentEditable editable> (and various other niceties). It's not the end 
of the world, but it's a bit of extra complexity. Reusing the attribute 
name and giving it a value that triggers new behaviour doesn't bring in 
the complications, but it does give us a relatively clean syntax entry 

Robin Berjon - http://berjon.com/ - @robinberjon
Received on Friday, 6 June 2014 13:52:07 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 18:14:25 UTC