[Bug 24087] New: [Custom]: Rename document.register to registerElement


            Bug ID: 24087
           Summary: [Custom]: Rename document.register to registerElement
           Product: WebAppsWG
           Version: unspecified
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Component Model
          Assignee: dglazkov@chromium.org
          Reporter: dominicc@chromium.org
        QA Contact: public-webapps-bugzilla@w3.org
                CC: mike@w3.org, public-webapps@w3.org

Based on the thread starting here:
document.register should be renamed to document.registerElement. It's more
specific about what this method does, lines up with other "register" methods
(eg registerProtocolHandler), and retains an imperative flavor (since it may
trigger callbacks.)

You are receiving this mail because:
You are on the CC list for the bug.

Received on Friday, 13 December 2013 06:03:10 UTC