[custom elements] Improving the name of document.register()

Hi,

The name "register" is very generic and could mean practically anything.
We need to adopt a name for document.register() that makes its purpose
clear to authors looking to use custom elements or those reading someone
else's code that makes use of custom elements.

Here are some ideas:

document.defineElement()
document.declareElement()
document.registerElementDefinition()
document.defineCustomElement()
document.declareCustomElement()
document.registerCustomElementDefinition()

I like document.defineCustomElement() the most, but
document.defineElement() also works for me if people think
document.defineCustomElement() is too long.


Ted

P.S. Sorry for the bikeshedding. I really believe we can improve the
name of this function to make its purpose clear.

Received on Wednesday, 11 December 2013 20:09:09 UTC