Re: [webcomponents]: Naming the Baby

Fwiw, my main concern is that for my team and for lots of other people I
communicate with, 'component' is basically synonymous with 'custom
element'. In that context, 'component' referring to
chunk-of-web-resources-loaded-via-link is problematic, even if it's not
wrong, per se.

We never complained about this before because Dimitri always wrote the
examples as <link rel="components"...> (note the plural). When it was
changed to <link rel="component"...> was when the rain began.


On Tue, Mar 26, 2013 at 4:08 PM, Ryan Seddon <> wrote:

> I like the idea of "package" seems all encompassing which captures the
> requirements nicely. That or perhaps "resource", but then resource seems
> singular.
> Or perhaps "component-package" so it is obvious that it's tied to web
> components?
> -Ryan
> On Tue, Mar 26, 2013 at 6:03 AM, Dimitri Glazkov <>wrote:
>> Hello folks!
>> It seems that we've had a bit of informal feedback on the "Web
>> Components" as the name for the <link rel=component> spec (cc'd some
>> of the "feedbackers").
>> So... these malcontents are suggesting that "Web Components" is more a
>> of a general name for all the cool things we're inventing, and <link
>> rel=component> should be called something more specific, having to do
>> with enabling modularity and facilitating component dependency
>> management that it actually does.
>> I recognize the problem, but I don't have a good name. And I want to
>> keep moving forward. So let's come up with a good one soon? As
>> outlined in
>> Rules:
>> 1) must reflect the intent and convey the meaning.
>> 2) link type and name of the spec must match.
>> 3) no biting.
>> :DG<

Received on Tuesday, 26 March 2013 23:20:29 UTC