Re: Feedback on Quota Management API

Based on the feedbacks I've updated the draft:

http://dvcs.w3.org/hg/quota/raw-file/tip/Overview.html

- Got rid of string enum, instead introduced navigator.persistentStorage
and navigator.temporaryStorage
- Some interface name changes (just for IDL)

  QuotaStorageEnvironment -> StorageQuotaEnvironment
  StorageInfo -> StorageQuota
  StorageInfoQuotaCallback -> StorageQuotaCallback
  StorageInfoUsageCallback -> StorageUsageCallback
  StorageInfoErrorCallback -> StorageErrorCallback

I'd like to finalize these naming/interface details while we're here.

On Tue, Jun 5, 2012 at 10:03 PM, Kinuko Yasuda <kinuko@chromium.org> wrote:

> On Mon, Jun 4, 2012 at 6:30 PM, Tobie Langel <tobie@fb.com> wrote:
>
>> On 6/4/12 11:17 AM, "Anne van Kesteren" <annevk@annevk.nl> wrote:
>>
>> >On Mon, Jun 4, 2012 at 11:01 AM, Tobie Langel <tobie@fb.com> wrote:
>> >> Finally, I feel it's slightly misleading to have an interface called
>> >> "info" which enables changes (through `requestQuota`). Wouldn't
>> >>"settings"
>> >> or similar be more appropriate? As in:
>> >>
>> >>    navigator.persistentStorageSettings.queryUsageAndQuota
>> >>    navigator.persistentStorageSettings.requestQuota
>> >>
>> >> Thoughts?
>> >
>> >That seems way long. navigator.storage would be better I think. Or
>> >even defining the relevant methods directly on navigator.
>>
>> Agreed. Whether you're targeting persistent or temp storage still needs to
>> appear somewhere, however.
>>
>> So it's either:
>>
>>    navigator.persistentStorage.requestQuota
>>
>> or:
>>
>>    navigator.storage.requestPersistentQuota
>>
>> or:
>>
>>
>>    navigator.requestPersistent(Storage)Quota
>>
>> I'd favor the first one.
>
>
> I like the first one too.  The third one sounds neat too but it may become
> too long for queryUsageAndQuota one (if we include Storage part).
>
> By the way even if we take navigator.persistentStorage or
> persistent.storage
> I'd still like to avoid using the name 'Storage' for the interface name
> (which would
> appear only on IDL), since we use the name for Web Storage and it's
> confusing.
>
> Maybe we could use StorageSettings for the interface name?
> Or how about StorageQuota (and renaming QuotaStorageEnv to
> StorageQuotaEnv)?
> Actually I like the latter one since it's shorter and reflects the API
> name better.
>
> --tobie
>>
>>
>>
>>
>

Received on Wednesday, 6 June 2012 06:34:47 UTC