Re: Feedback on Quota Management API

On 6/1/12 12:07 PM, "Kinuko Yasuda" <kinuko@chromium.org> wrote:
> Makes sense, ok let's keep it.  Then we will have symmetric four
>methods, request and query for each type.

Following up on the conversation on Quota Management API and the recent
changes which were agreed upon, I'm wondering whether we shouldn't also
consider the following: Instead of:

    navigator.storageInfo.queryPersistentUsageAndQuota
    navigator.storageInfo.queryTemporaryUsageAndQuota
    navigator.storageInfo.requestPersistentQuota
    navigator.storageInfo.requestTemporaryQuota

what about:

    navigator.persistentStorageInfo.queryUsageAndQuota
    navigator.persistentStorageInfo.requestQuota

    navigator.temporaryStorageInfo.queryUsageAndQuota
    navigator.temporaryStorageInfo.requestQuota

i.e. instead of having the `QuotaStorageEnvironment` interface define a
single `storageInfo` attribute off of which all 4 methods hang, what about
having it define two attributes of type `PersistentStorageInfo` and
`TemporaryStorageInfo` respectively, each of which would only have a query
and request method?

Finally, I feel it's slightly misleading to have an interface called
"info" which enables changes (through `requestQuota`). Wouldn't "settings"
or similar be more appropriate? As in:

    navigator.persistentStorageSettings.queryUsageAndQuota
    navigator.persistentStorageSettings.requestQuota

Thoughts?

--tobie

Received on Monday, 4 June 2012 09:04:51 UTC