Re: [XHR2] ArrayBuffer integration

I plan to add ArrayBuffer support to BlobBuilder and FileReader. Chris, it
is good that you would pick up the work for XHR. We can talk about how we're
going to add ArrayBufferView to read ArrayBuffer.

Jian

On Fri, Sep 24, 2010 at 5:23 PM, Kenneth Russell <kbr@google.com> wrote:

> On Thu, Sep 23, 2010 at 2:42 AM, Anne van Kesteren <annevk@opera.com>
> wrote:
> > On Wed, 08 Sep 2010 19:55:33 +0200, Kenneth Russell <kbr@google.com>
> wrote:
> >>
> >> Mozilla's experimental name is "mozResponseArrayBuffer", so perhaps to
> >> avoid collisions the spec could call it responseArrayBuffer.
> >
> > While I do not think there would be collision (at least not in
> ECMAScript,
> > which is what we are designing for) naming it responseArrayBuffer is fine
> > with me. And also now done that way in the draft. Still need to get a
> saner
> > reference to the ArrayBuffer specification than
> >
> https://cvs.khronos.org/svn/repos/registry/trunk/public/webgl/doc/spec/TypedArray-spec.html
> > though. :-)
> >
> > http://dev.w3.org/2006/webapi/XMLHttpRequest-2/
>
> Thanks, this is great and very exciting. This motivates implementing
> the proposed DataView interface (
>
> https://cvs.khronos.org/svn/repos/registry/trunk/public/webgl/doc/spec/TypedArray-spec.html#6
> ), which will make it easier to read multi-byte values with specified
> endianness out of an ArrayBuffer. For WebKit I've filed
> https://bugs.webkit.org/show_bug.cgi?id=46541 .
>
> -Ken
>
> > (You can also do send(ArrayBuffer) obviously. I personally think
> supporting
> > this for both BlobBuilder and send() makes sense. That way Blob/File etc.
> > work too.)
> >
> >
> > --
> > Anne van Kesteren
> > http://annevankesteren.nl/
> >
>
>

Received on Saturday, 25 September 2010 00:37:24 UTC