- From: ben turner <bent.mozilla@gmail.com>
- Date: Wed, 22 Sep 2010 13:11:20 -0700
- To: public-webapps WG <public-webapps@w3.org>
Hi folks, The spec currently says that IDBDatabase.transaction() takes an array of object store names as its first parameter. While I think this is fine I'd like to propose that we loosen that restriction and allow a simple string to name one object store as well. Thus this code: var transaction = database.transaction(["foo"]); could, additionally, be written as: var transaction = database.transaction("foo"); I of course would like the array syntax to continue to be valid for one or more object store names. What do you guys think? -Ben
Received on Wednesday, 22 September 2010 20:12:14 UTC